Introduction to LabVIEW

LabVIEW

• Laboratory Virtual Instrument Engineering Workbench
• First released by National Instruments in 1986, this graphical programming language is now the standard software for data acquisition (DAQ) and instrument control
Introduction

• LabVIEW programs are called virtual instruments, or VIs, because their appearance and operation imitate physical instruments, such as oscilloscopes and multimeters.

• LabVIEW contains a comprehensive set of tools for acquiring, analyzing, displaying, and storing data, as well as tools to help you troubleshoot code you write.
### The NI Approach – Integrated Hardware Platforms

- **High-Speed Digitizers**
- **High-Resolution Digitizers and DMMs**
- **Multifunction Data Acquisition**
- **Dynamic Signal Acquisition**
- **Digital I/O Instrument Control**
- **Counter/Timers**
- **Machine Vision**
- **Motion Control**
- **Distributed I/O and Embedded Control**

### Signal Conditioning and Switching

**Unit Under Test**

### What type of device should I use?

<table>
<thead>
<tr>
<th></th>
<th>Sound Card*</th>
<th>NI USB DAQ</th>
<th>NI PCI DAQ</th>
<th>Instruments*</th>
</tr>
</thead>
<tbody>
<tr>
<td>AI Bandwidth</td>
<td>8–44 KS/s</td>
<td>10–200 KS/s</td>
<td>250 K–1.2 Ms/s</td>
<td>20 kS/s–2 GS/s</td>
</tr>
<tr>
<td>Accuracy</td>
<td>12–16 bit</td>
<td>12–16 bit</td>
<td>14–18 bit</td>
<td>12–24 bit</td>
</tr>
<tr>
<td>Portable</td>
<td>x</td>
<td>x</td>
<td>–</td>
<td>some</td>
</tr>
<tr>
<td>AI Channels</td>
<td>2</td>
<td>8–16</td>
<td>16–80</td>
<td>2</td>
</tr>
<tr>
<td>AO Channels</td>
<td>2</td>
<td>1–2</td>
<td>2–4</td>
<td>0</td>
</tr>
<tr>
<td>AC or DC</td>
<td>AC</td>
<td>AC/DC</td>
<td>AC/DC</td>
<td>AC/DC</td>
</tr>
<tr>
<td>Triggering</td>
<td>–</td>
<td>x</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Calibrated</td>
<td>–</td>
<td>x</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

*The above table may not be representative of all device variations that exist in each category.*
Setting Up Hardware

• Data Acquisition Device (DAQ)
  – Actual USB, PCI, or PXI Device
  – Configured in MAX

• Simulated Data Acquisition Device (DAQ)
  – Software simulated at the driver level
  – Configured in MAX

• Sound Card
  – Built into most computers

What is MAX?

• MAX stands for Measurement & Automation Explorer.
• MAX configures and organizes all your National Instruments DAQ, PCI/PXI instruments, GPIB, IMAQ, IVI, Motion, VISA, and VXI devices.
• Used for configuring and testing devices.
Setting Up Hardware

• Use Windows to:
  – Verify a Sound Card

• Use Measurement and Automation Explorer (MAX) to:
  – Configure and test your Data Acquisition (DAQ) device
Introduction

• In LabVIEW, you build a user interface, or front panel, with controls and indicators

• Controls are knobs, push buttons, dials, and other input mechanisms; indicators are graphs, LEDs, and other output displays

• After you build the user interface, you add code using VIs and structures to control the front panel objects

• The block diagram contains this code
Each VI has 2 Windows

Front Panel
• User Interface (UI)
  – Controls = Inputs
  – Indicators = Outputs

Block Diagram
• Graphical Code
  – Data travels on wires from controls through functions to indicators
  – Blocks execute by Dataflow

LabVIEW Programs Are Called Virtual Instruments (VIs)
What Types of Controls and Indicators are Available?

- **Numeric Data**
  - Number input and display
  - Analog Sliders, Dials, and Gauges
- **Boolean Data**
  - Buttons and LEDs
- **Array & Matrix Data**
  - Numeric Display
  - Chart
  - Graph
  - XY Graph
  - Intensity Graph
  - 3D graph: point, surface, and model
- **Decorations**
  - Tab Control
  - Arrows
- **Other**
  - Strings and text boxes
  - Picture/Image Display
  - ActiveX Controls
Functions (and Structures) Palette

(Place items on the Block Diagram Window)

Structure: While Loop

What Types of Functions are Available?

• Input and Output
  – Signal and Data Simulation
  – Acquire and Generate Real Signals with DAQ
  – Instrument I/O Assistant (Serial & GPIB)
  – ActiveX for communication with other programs

• Analysis
  – Signal Processing
  – Statistics
  – Advanced Math and Formulas
  – Continuous Time Solver

• Storage
  – File I/O
Dataflow Programming

• Block diagram execution
  – Dependent on the flow of data
  – Block diagram does NOT execute left to right
• Node executes when data is available to ALL input terminals
• Nodes supply data to all output terminals when done

Elements of Typical Programs

A. Loops
  • While Loop
  • For Loop

B. Functions and SubVIs
  • Types of Functions
  • Creating Custom Functions (SubVI)
  • Functions Palette & Searching

C. Decision Making and File I/O
  • Case Structure
  • Select (simple If statement)
  • File I/O
Loops

• While Loops
  - terminal counts iteration
  - Always runs at least once
  - Runs until stop condition is met

• For Loops
  - terminal counts iterations
  - Run according to input N of count terminal

Drawing a Loop

1. Select the structure
2. Enclose code to be repeated
3. Drop or drag additional nodes and then wire
3 Types of Functions (from the Functions Palette)

Express VIs: interactive VIs with configurable dialog page (blue border)

Standard VIs: modularized VIs customized by wiring (customizable)

Functions: fundamental operating elements of LabVIEW; no front panel or block diagram (yellow)

How Do I Make Decisions in LabVIEW?

1. Case Structures

2. Select
Presenting your Results

A. Displaying Data on the Front Panel
   • Controls and Indicators
   • Graphs and Charts
   • Loop Timing

B. Signal Processing
   • MathScript
   • Arrays
   • Clusters
   • Waveforms

Charts – Add 1 data point at a time with history

**Waveform chart** – special numeric indicator that can display a history of values

- Chart updates with each individual point it receives

Functions » Express » Graph Indicators » Chart

![Waveform Chart Diagram](image-url)
Graphs – Display many data points at once

**Waveform graph** – special numeric indicator that displays an array of data

- Graph updates after all points have been collected
- May be used in a loop if VI collects buffers of data

**Functions** ➔ **Express** ➔ **Graph Indicators** ➔ **Graph**

### Building Arrays with Loops (Auto-Indexing)

- Loops can accumulate arrays at their boundaries with auto-indexing
- For Loops auto-index by default
- While Loops output only the final value by default
- Right-click tunnel and enable/disable auto-indexing
How Do I Time a Loop?

1. Loop Time Delay
   - Configure the Time Delay Express VI for seconds to wait each iteration of the loop (works on For and While loops).

2. Timed Loops
   - Configure special timed While loop for desired $dt$.

Textual Math in LabVIEW

- Integrate existing scripts with LabVIEW for faster development
- Interactive, easy-to-use, hands-on learning environment
- Develop algorithms, explore mathematical concepts, and analyze results using a single environment
- Freedom to choose the most effective syntax, whether graphical or textual within one VI

Supported Math Tools:
- MathScript script node
- MathSoft software
- Mathematica software
- MATLAB® software
- Maple software
- Xmath software
MATLAB (MATrix LABoratory)

- The goal of MATLAB is to enable the users to solve a wide spectrum of analytical and numerical problems using matrix-based methods, attain excellent interfacing and interactive capabilities, provide easy access to and straightforward implementation of state-of-the-art numerical algorithms, guarantee powerful graphical features, etc.
- Due to high flexibility and versatility, MATLAB has evolved over the last 20 years and become one of the most useful tools for scientific and engineering calculations and computing

Introduction to Clusters

- Data structure that groups data together
- Data may be of different types
- Analogous to *struct* in C
- Elements must be either all controls or all indicators
- Thought of as wires bundled into a cable
- **Order is important**
Review of Data Types Found in LabVIEW

- Boolean
- Double Precision Number
- Integer Number
- Complex Number
- 1D Array of Doubles
- 2D Array of Doubles
- Matrix of Doubles
- String
- Waveform Cluster
- Waveform Graph
- Error Cluster
- Text In (Case aware)
- Simulate Signal
- Dynamic Data

Modularity in LabVIEW – SubVIs

Convert repeated functions and VIs with a single VI
Create SubVI

- Enclose area to be converted into a subVI.
- Select **Edit»Create SubVI** from the Edit Menu.

Instrument Control

A. Overview of Instrument Control
B. GPIB
C. Serial
D. Instrument I/O Assistant
E. VISA
F. Instrument Drivers and IDNET
LabVIEW programs are called virtual instruments, or VIs, because their appearance and operation imitate physical instruments, such as oscilloscopes and multimeters. LabVIEW contains a comprehensive set of tools for acquiring, analyzing, displaying, and storing data, as well as tools to help you troubleshoot code you write.

In LabVIEW, you build a user interface, or front panel, with controls and indicators. Controls are knobs, push buttons, dials, and other input mechanisms. Indicators are graphs, LEDs, and other output displays. After you build the user interface, you add code using VIs and structures to control the front panel objects. The block diagram contains this code.

You can use LabVIEW to communicate with hardware such as data acquisition, vision, and motion control devices, as well as GPIB, PXI, VXI, RS232, and RS485 instruments.

Building a Virtual Instrument

In the following exercises, you will build a VI that generates a signal and displays that signal in a graph. After you complete the exercises, the front panel of the VI will look similar to the front panel in Figure 1-1.

You can complete the exercises in this chapter in approximately 40 minutes.
Launching LabVIEW

The **Getting Started** window, shown in Figure 1-2, appears when you launch LabVIEW. Use this window to create new VIs, select among the most recently opened LabVIEW files, find examples, and launch the *LabVIEW Help*. You also can access information and resources to help you learn about LabVIEW, such as specific manuals, help topics, and resources on the National Instruments Web site, [ni.com](http://ni.com).
Chapter 1  Getting Started with LabVIEW Virtual Instruments

Figure 1-2. Getting Started Window

The **Getting Started** window disappears when you open an existing file or create a new file. The **Getting Started** window reappears when you close all open front panels and block diagrams. You also can display the window from the front panel or block diagram by selecting View»Getting Started Window.

**Opening a New VI from a Template**

LabVIEW provides built-in template VIs that include the subVIs, functions, structures, and front panel objects you need to get started building common measurement applications.

Complete the following steps to create a VI that generates a signal and displays it on the front panel.

1. Launch LabVIEW.
2. In the **Getting Started** window, click the **New or VI from Template** link to display the **New** dialog box.

3. From the **Create New** list, select **VI»From Template»Tutorial (Getting Started)»Generate and Display**. This template VI generates and displays a signal.

   A preview and a brief description of the template VI appear in the **Description** section. Figure 1-3 shows the **New** dialog box and the preview of the Generate and Display template VI.

   ![New Dialog Box](image)

   **Figure 1-3.** New Dialog Box

4. Click the **OK** button to create a VI from the template. You also can double-click the name of the template VI in the **Create New** list to create a VI from a template.
5. Examine the front panel of the VI.
The user interface, or front panel, appears with a gray background and
includes controls and indicators. The title bar of the front panel
indicates that this window is the front panel for the Generate and
Display VI.

**Note** If the front panel is not visible, you can display the front panel by selecting
Window»Show Front Panel. You also can switch between the front panel window and
block diagram window at any time by pressing the <Ctrl-E> keys. The <Ctrl> key in
keyboard shortcuts corresponds to the (Mac OS) <Option> or <Command> key or (Linux)
<Alt> key.

6. Select Window»Show Block Diagram and examine the block
diagram of the VI.
The block diagram appears with a white background and includes VIs
and structures that control the front panel objects. The title bar of the
block diagram indicates that this window is the block diagram for the
Generate and Display VI.

7. On the front panel toolbar, click the Run button, shown at left. You
also can press the <Ctrl-R> keys to run a VI.
A sine wave appears on the graph on the front panel.

8. Stop the VI by clicking the STOP button, shown at left, on the front
panel.

### Adding a Control to the Front Panel
Controls on the front panel simulate the input mechanisms on a physical
instrument and supply data to the block diagram of the VI. Many physical
instruments have knobs you can turn to change an input value.

Complete the following steps to add a knob control to the front panel.

**Tip** Throughout these exercises, you can undo recent edits by selecting Edit»Undo or
pressing the <Ctrl-Z> keys.

1. If the Controls palette, shown in Figure 1-4, is not visible on the front
panel, select View»Controls Palette.

**Tip** You can right-click any blank space on the front panel or the block diagram to display
a temporary version of the Controls or Functions palettes. The Controls or Functions
palette appears with a thumbtack icon in the upper left corner. Click the thumbtack to pin
the palette so it is no longer temporary.
2. If you are a new LabVIEW user, the **Controls** palette opens with the **Express** subpalette visible by default. If you do not see the **Express** subpalette, click **Express** on the **Controls** palette to display the **Express** subpalette.

![Controls Palette](image)

**Figure 1-4. Controls Palette**

3. Move the cursor over the icons on the **Express** subpalette to locate the **Numeric Controls** palette.

When you move the cursor over icons on the **Controls** palette, the name of the subpalette, control, or indicator appears in a tip strip below the icon.

4. Click the **Numeric Controls** icon to display the **Numeric Controls** palette.

5. Click the knob control on the **Numeric Controls** palette to attach the control to the cursor, then place the knob on the front panel to the left of the waveform graph.

You will use this knob in a later exercise to control the amplitude of a signal.

6. Select **File»Save As** and save the VI as **Acquiring a Signal.vi** in an easily accessible location.
Changing a Signal Type

The block diagram has a blue icon labeled Simulate Signal. This icon represents the Simulate Signal Express VI. The Simulate Signal Express VI simulates a sine wave by default.

Complete the following steps to change this signal to a sawtooth wave.

1. Display the block diagram by pressing the <Ctrl-E> keys or by clicking the block diagram.

   Locate the Simulate Signal Express VI, shown at left. An Express VI is a component of the block diagram that you can configure to perform common measurement tasks. The Simulate Signal Express VI simulates a signal based on the configuration that you specify.

2. Right-click the Simulate Signal Express VI and select Properties from the shortcut menu to display the Configure Simulate Signal dialog box. (Mac OS) Press <Command>-click to perform the same action as right-click.

   You also can double-click the Express VI to display the Configure Simulate Signal dialog box. If you wire data to an Express VI and run it, the Express VI displays real data in the configuration dialog box. If you close and reopen the Express VI, the VI displays sample data in the configuration dialog box until you run the VI again.

3. Select Sawtooth from the Signal type pull-down menu.

   The waveform on the graph in the Result Preview section changes to a sawtooth wave. The Configure Simulate Signal dialog box should appear similar to Figure 1-5.
4. Click the **OK** button to save the current configuration and close the **Configure Simulate Signal** dialog box.

5. Move the cursor over the down arrows at the bottom of the Simulate Signal Express VI. The down arrows indicate you can reveal hidden inputs and outputs by extending the border of the Express VI.

6. When a double-headed arrow appears, shown at left, click and drag the border of the Express VI to add two rows. When you release the border, the **Amplitude** input appears.

   Because the **Amplitude** input appears on the block diagram, you can configure the amplitude of the sawtooth wave on the block diagram.

In Figure 1-5, notice that **Amplitude** is an option in the **Configure Simulate Signal** dialog box. When inputs, such as **Amplitude**, appear on the block diagram and in the configuration dialog box, you can configure the inputs in either location.
Wiring Objects on the Block Diagram

To use the knob to change the amplitude of the signal, you must connect two objects on the block diagram.

Complete the following steps to wire the knob to the **Amplitude** input of the Simulate Signal Express VI.

1. On the block diagram, move the cursor over the **Knob** terminal, shown at left.
   The cursor becomes an arrow, or the Positioning tool, shown at left. Use the Positioning tool to select, position, and resize objects.

2. Use the Positioning tool to select the **Knob** terminal and make sure it is to the left of the Simulate Signal Express VI and inside the gray loop, shown at left.
   The terminals inside the loop are representations of front panel controls and indicators. Terminals are entry and exit ports that exchange information between the front panel and block diagram.

3. Deselect the **Knob** terminal by clicking a blank space on the block diagram. If you want to use a different tool with an object, you must deselect the object to switch the tool.

4. Move the cursor over the arrow on the **Knob** terminal, shown at left.
   The cursor becomes a wire spool, or the Wiring tool, shown at left. Use the Wiring tool to wire objects together on the block diagram.

5. When the Wiring tool appears, click the arrow on the **Knob** terminal and then click the arrow on the **Amplitude** input of the Simulate Signal Express VI, shown at left, to wire the two objects together.
   A wire appears and connects the two objects. Data flows along this wire from the **Knob** terminal to the Express VI.

6. Select **File»Save** to save the VI.
Running a VI executes the solution.

Complete the following steps to run the Acquiring a Signal VI.

1. Display the front panel by pressing the <Ctrl-E> keys or by clicking the front panel.
2. Click the Run button or press the <Ctrl-R> keys to run the VI.
3. Move the cursor over the knob.
   The cursor becomes a hand, or the Operating tool, shown at left. Use the Operating tool to change the value of a control.
4. Using the Operating tool, turn the knob to adjust the amplitude of the sawtooth wave.
   The amplitude of the sawtooth wave changes as you turn the knob. As you change the amplitude, the Operating tool displays a tip strip that indicates the numeric value of the knob. The y-axis on the graph scales automatically to account for the change in amplitude.
   To indicate that the VI is running, the Run button changes to a darkened arrow, shown at left. You can change the value of most controls while a VI runs, but you cannot edit the VI in other ways while the VI runs.
5. Click the STOP button, shown at left, to stop the VI.
   The STOP button stops the VI after the VI completes the current iteration. The Abort Execution button, shown at left, stops the VI immediately, before the VI finishes the current iteration. Aborting a VI that uses external resources, such as external hardware, might leave the resources in an unknown state by not resetting or releasing them properly. Design the VIs you create with a stop button to avoid this problem.
Modify a Signal

Complete the following steps to scale the signal by 10 and display the results in the graph on the front panel.

1. On the block diagram, use the Positioning tool to double-click the wire that connects the Simulate Signal Express VI to the Waveform Graph terminal, shown at left.

2. Press the <Delete> key to delete this wire.

3. If the Functions palette, shown in Figure 1-6, is not visible, select View»Functions Palette to display it. The Functions palette opens with the Express subpalette visible by default. If you have selected another subpalette, you can return to the Express subpalette by clicking Express on the Functions palette.

4. On the Arithmetic & Comparison palette, select the Formula Express VI, shown at left, and place it on the block diagram inside the loop between the Simulate Signal Express VI and the Waveform Graph terminal. You can move the Waveform Graph terminal to the right to make more room between the Express VI and the terminal.

The Configure Formula dialog box appears when you place the Express VI on the block diagram. When you place an Express VI on the block diagram, the configuration dialog box for that VI always appears automatically.

5. Click the Help button, shown at left, in the bottom right corner of the Configure Formula dialog box to display the LabVIEW Help topic for this Express VI.

The Formula help topic describes the Express VI, the configuration dialog box options, and the inputs and outputs of the Express VI. Each Express VI has a corresponding help topic you can access by clicking
the Help button in the configuration dialog box or by right-clicking the Express VI and selecting Help from the shortcut menu.

6. In the Formula topic, find the dialog box option whose description indicates that it enters a variable into the formula.

7. Minimize the LabVIEW Help to return to the Configure Formula dialog box.

8. Change the text in the Label text box of the dialog box option you read about from x1 to Sawtooth to indicate the input value to the Formula Express VI. When you click in the String text box at the top of the Configure Formula dialog box, the text changes to match the label you entered.

9. Define the value of the scaling factor by entering *10 after Sawtooth in the String text box.

   You can use the Input buttons in the configuration dialog box or you can use the *, 1, and 0 keyboard buttons to enter the scaling factor. If you use the Input buttons in the configuration dialog box, LabVIEW places the formula input after the Sawtooth input in the String text box. If you use the keyboard, click in the String text box after Sawtooth and enter the formula you want to appear in the text box.
Chapter 1  Getting Started with LabVIEW Virtual Instruments

The **Configure Formula** dialog box should appear similar to Figure 1-7.

![Configure Formula Dialog Box](image)

**Figure 1-7.** Configure Formula Dialog Box

**Note**  If you enter a formula in the **String** text box that is not valid, the **Errors** LED, in the upper right corner turns gray and displays the text **Invalid Formula**.

10. Click the **OK** button to save the current configuration and close the **Configure Formula** dialog box.

11. Move the cursor over the arrow on the **Sawtooth** output of the Simulate Signal Express VI.

12. When the Wiring tool appears, click the arrow on the **Sawtooth** output and then click the arrow on the **Sawtooth** input of the Formula Express VI, shown at left, to wire the two objects together.

13. Use the Wiring tool to wire the **Result** output of the Formula Express VI to the **Waveform Graph** terminal.
Examine the wires connecting the Express VIs and terminals. The arrows on the Express VIs and terminals indicate the direction that the data flows along these wires. The block diagram should appear similar to Figure 1-8.

**Tip** You can right-click any wire and select **Clean Up Wire** from the shortcut menu to have LabVIEW automatically find a route for the wire around existing objects on the block diagram. LabVIEW also routes a wire to decrease the number of bends in the wire.

![Block Diagram of the Acquiring a Signal VI](image)

**Figure 1-8.** Block Diagram of the Acquiring a Signal VI

14. Press the `<Ctrl-S>` keys or select **File ➤ Save** to save the VI.

### Displaying Two Signals on a Graph

To compare the signal generated by the Simulate Signal Express VI and the signal modified by the Formula Express VI on the same graph, use the Merge Signals function.

Complete the following steps to display two signals on the same graph.

1. On the block diagram, move the cursor over the arrow on the *Sawtooth* output of the Simulate Signal Express VI.
2. Use the Wiring tool to wire the *Sawtooth* output to the *Waveform Graph* terminal.

The Merge Signals function, shown at left, appears where the two wires connect. A function is a built-in execution element, comparable to an operator, function, or statement in a text-based programming language. The Merge Signals function takes the two separate signals and combines them so that both can display on the same graph.
The block diagram should appear similar to Figure 1-9.

3. Press the <Ctrl-S> keys or select File»Save to save the VI.
4. Return to the front panel, run the VI, and turn the knob control.

The graph plots the sawtooth wave and the scaled signal. The maximum value on the y-axis automatically changes to be 10 times the knob value. This scaling occurs because you configured the Formula Express VI to generate a slope of 10.

5. Click the STOP button to stop the VI.

**Customizing a Knob Control**

The knob control changes the amplitude of the sawtooth wave, so labeling it **Amplitude** accurately describes the behavior of the knob.

Complete the following steps to customize the appearance of the knob.

1. On the front panel, right-click the knob and select Properties from the shortcut menu to display the **Knob Properties** dialog box.
2. In the Label section on the Appearance page, delete the label **Knob**, and enter **Amplitude** in the text box.
The **Knob Properties** dialog box should appear similar to Figure 1-10.

![Knob Properties Dialog Box](image)

**Figure 1-10.** Knob Properties Dialog Box

3. Click the **Scale** tab and in the **Scale Style** section, place a checkmark in the **Show color ramp** checkbox.

   The knob on the front panel updates to reflect these changes.

4. Click the **OK** button to save the current configuration and close the **Knob Properties** dialog box.

5. Save the VI.

6. Reopen the **Knob Properties** dialog box and experiment with other properties of the knob. For example, on the **Scale** page, try changing the colors for the **Marker text color** by clicking the color box.

7. Click the **Cancel** button to avoid applying any changes you made while experimenting. If you want to keep the changes you made, click the **OK** button.
Customizing a Waveform Graph

The waveform graph indicator displays the two signals. To indicate which plot is the scaled signal and which is the simulated signal, you can customize the plots.

Complete the following steps to customize the appearance of the waveform graph indicator:

1. On the front panel, move the cursor over the top of the plot legend on the waveform graph.
   Though the graph has two plots, the plot legend displays only one plot.

2. When a double-headed arrow appears, shown in Figure 1-11, click and drag the border of the plot legend to add one item to the legend. When you release the mouse button, the second plot name appears.

3. Right-click the waveform graph and select Properties from the shortcut menu to display the Waveform Graph Properties dialog box.

4. On the Plots page, select Sawtooth from the pull-down menu. In the Colors section, click the Line color box to display the color picker. Select a new line color.

5. Select Sawtooth (Formula Result) from the pull-down menu.

6. Place a checkmark in the Do not use waveform names for plot names checkbox.

7. In the Name text box, delete the current label and change the name of this plot to Scaled Sawtooth.
8. Click the **OK** button to save the current configuration and close the **Waveform Graph Properties** dialog box.
   The plot color on the front panel changes.

9. Reopen the **Waveform Graph Properties** dialog box and experiment with other properties of the graph. For example, on the **Scales** page, try disabling automatic scaling and changing the minimum and maximum value of the y-axis.

10. Click the **Cancel** button to avoid applying any changes you made while experimenting. If you want to keep the changes you made, click the **OK** button.

11. Save and close the VI.

**Summary**

The following topics are a summary of the main concepts you learned in this chapter.

**New Dialog Box and Template VIs**

The **New** dialog box contains many template VIs, including the ones used in this manual. The template VIs help you start building VIs for common measurements and other tasks. The template VIs include the Express VIs, functions, and front panel objects you need to get started building common measurement applications.

Use one of the following methods to access the **New** dialog box:

- Click the **New, VI from Template**, or **More** links in the **Getting Started** window after you start LabVIEW.
- Select **File»New** from the menu bar of the **Getting Started** window, the front panel, or the block diagram.

**Front Panel**

The front panel is the user interface of a VI. You build the front panel by using controls and indicators, which are the interactive input and output terminals of the VI, respectively. Controls and indicators are located on the **Controls** palette.

Controls are knobs, push buttons, dials, and other input mechanisms. Controls simulate instrument input mechanisms and supply data to the block diagram of the VI.
3

Full and Professional: Analyzing and Saving a Signal

LabVIEW includes a set of Express VIs that help you analyze signals. This chapter teaches you how to use LabVIEW to perform a basic analysis of a signal and how to save the analyzed data to a file.

Note  The exercises in this chapter use Express VIs that are available only in the LabVIEW Full and Professional Development Systems.

Building an Analysis VI

In the following exercises, you will build a VI that generates a signal, filters the signal, indicates if the signal exceeds a certain limit, and records the data. After you complete the exercises, the front panel of the VI will look similar to the front panel in Figure 3-1.

You can complete the exercises in this chapter in approximately 40 minutes.
Chapter 3 Full and Professional: Analyzing and Saving a Signal

Getting Started with LabVIEW

Figure 3-1. Front Panel of the Save Data VI

Modifying a VI Created from a Template

Complete the following steps to create a VI that generates, analyzes, and displays a signal:

1. In the Getting Started window, click New to display the New dialog box.

2. From the Create New list, select VI»From Template»Tutorial (Getting Started)»Generate, Analyze, and Display. This template VI simulates a signal and analyzes it for its root mean square (RMS) value.

3. Click the OK button or double-click the name of the template to create a VI from the template.

4. If the Context Help window is not visible, press the <Ctrl-H> keys to display the window. (Mac OS) Press the <Command-Shift-H> keys.

5. Display the block diagram by pressing the <Ctrl-E> keys.

6. Move the cursor over the Amplitude and Level Measurements Express VI, shown at left.

The Context Help window displays information about the behavior of the Express VI.
Keep the Context Help window open. It will provide useful information as you complete the rest of this exercise.

7. On the front panel, remove the RMS indicator along with any broken wires on the block diagram that result from removing the indicator. To remove all broken wires from the block diagram, you can press the <Ctrl-B> keys.

You will not use the RMS functionality of the Amplitude and Level Measurements Express VI for this exercise. However, you can use the Generate, Analyze, and Display template VI with the RMS functionality in a future project to reduce development time.

8. On the front panel, right-click the waveform graph indicator and select Properties from the shortcut menu. The Graph Properties dialog box appears.

9. On the Appearance tab, place a checkmark in the Visible checkbox in the Label section and enter Unfiltered Signal in the text box.

10. Click the OK button to save the configuration and close the Graph Properties dialog box.

11. Run the VI.

The signal appears in the graph.

12. Click the STOP button to stop the VI.

Adding a Signal

The Simulate Signal Express VI simulates a sine wave by default. You can customize the simulated signal by changing the options in the Configure Simulate Signal dialog box.

Complete the following steps to create an additional simulated signal that adds uniform white noise to the sine wave.

1. On the block diagram, use the Positioning tool to select the Simulate Signal Express VI.

   Hold down the <Ctrl> key and drag to create an additional Simulate Signal Express VI on the block diagram. (Mac OS) Hold down the <Option> key and drag. (Linux) Hold down the middle mouse button and drag.

2. Release the mouse button to place the copied Simulate Signal Express VI below the original Simulate Signal Express VI. LabVIEW updates the name of the copied Simulate Signal Express VI to Simulate Signal2.
3. Double-click the Simulate Signal2 Express VI to display the Configure Simulate Signal dialog box.
4. Select Sine from the Signal type pull-down menu.
5. Enter 60 in the Frequency (Hz) text box.
6. Enter .1 in the Amplitude text box.
7. Place a checkmark in the Add noise checkbox to add noise to the sine signal.
8. Select Uniform White Noise from the Noise type pull-down menu.
9. Enter 0.1 in the Noise amplitude text box.
10. Enter -1 in the Seed number text box.
11. In the Timing section, select the Run as fast as possible option.
12. In the Signal Name section, remove the checkmark from the Use signal type name checkbox.
13. Enter 60 Hz and Noise in the Signal name text box.

When you change the signal name in the Configure Simulate Signal dialog box, LabVIEW changes the name of the signal output on the block diagram. Changing the signal name makes it easier for you to identify the signal type when you view the Express VI on the block diagram.

The Result Preview section displays a random signal. The Configure Simulate Signal dialog box should appear similar to Figure 3-2.
14. Click the **OK** button to save the current configuration and close the **Configure Simulate Signal** dialog box.

**Adding Two Signals**

To add two signals together to create one signal, you can use the Formula Express VI. Rather than merging two signals on one graph, the Formula Express VI adds both signals together to create a single signal on the graph. You can use this Express VI to add noise to a signal.

Complete the following steps to **add the 60 Hz and Noise signal to the Sine signal**.

1. On the block diagram, triple-click the wire that connects the **Sine** output of the Simulate Signal Express VI to the **Signals** input of the Amplitude and Level Measurements Express VI and to the **Unfiltered Signal** indicator and remove the wire.

2. Click the **Search** button on the **Functions** palette to search for the Formula Express VI, and place it on the block diagram between the
Simulate Signal Express VIs and the Amplitude and Level Measurements Express VI.

3. The **Configure Formula** dialog box appears in the **Label** column. Change the label for **X1** to **Sine** and the label for **X2** to **60 Hz and Noise**.

4. Click the **Input** and **+** buttons to add **Sine** and **60 Hz and Noise** together in the **String** text box.

5. Click the **OK** button to save the current configuration and close the **Configure Formula** dialog box.

6. Use the Wiring tool to wire the **Sine** output of the Simulate Signal Express VI to the **Sine** input of the Formula Express VI.

7. Wire the **60 Hz and Noise** output of the Simulate Signal2 Express VI to the **60 Hz and Noise** input of the Formula Express VI.

8. Wire the **Result** output of the Formula Express VI to the **Unfiltered Signal** indicator and to the **Signals** input of the Amplitude and Level Measurements Express VI.

9. Display the front panel by pressing the <Ctrl-E> keys.

10. Run the VI.

11. The signal with added noise appears in the graph.

12. Click the **STOP** button to stop the VI.

13. Select **File»Save As** and save the VI as **Analysis.vi** in an easily accessible location.

### Filtering a Signal

You can use the Filter Express VI to process signals through filters and windows.

Complete the following steps to configure the Filter Express VI to **filter the signal using an infinite impulse response (IIR) filter**.

1. Remove the wire that connects the **Result** output of the Formula Express VI to the **Signals** input of the Amplitude and Level Measurements Express VI.

2. Remove all broken wires that result from removing the wire.

3. Search for the Filter Express VI and place it on the block diagram between the Simulate Signal2 Express VI and the Amplitude and Level Measurements Express VI. The **Configure Filter** dialog box appears.

4. In the **Filter Specifications** section, change the **Cutoff Frequency (Hz)** to 25.
5. Click the OK button to save the configuration and close the **Configure Filter** dialog box.

6. Display the front panel.

7. Click the **Unfiltered Signal** waveform graph indicator on the front panel and press the <Ctrl> key while you drag to create an additional waveform graph indicator.

8. Place the additional waveform graph indicator below the **Unfiltered Signal** waveform graph.

9. Triple-click the **Unfiltered Signal 2** label above the new waveform graph indicator and enter **Filtered Signal** to change the label of the indicator. You also can change the label on the Appearance page of the **Graph Properties** dialog box.

10. On the block diagram, wire the **Result** output of the Formula Express VI to the **Signal** input of the Filter Express VI.

11. Wire the **Filtered Signal** output of the Filter Express VI to the **Signals** input of the Amplitude and Level Measurements Express VI and to the input of the **Filtered Signal** waveform graph indicator.

12. Select **File»Save**. The block diagram of the Analysis VI should appear similar to Figure 3-3.

![Figure 3-3. Block Diagram of the Analysis VI](image)

### Modifying the Appearance of Graphs

You can use the **Format and Precision** page of the **Graph Properties** dialog box to specify how the scales of the x-axis and y-axis appear on the graph.
Complete the following steps to change the format of the x-axis and y-axis of the Unfiltered Signal and Filtered Signal graphs.

1. On the front panel, right-click the Unfiltered Signal graph indicator and select Properties from the shortcut menu. The Graph Properties dialog box appears.
2. On the Format and Precision page, select Time (X-Axis) from the top pull-down menu.
3. In the Type list, select Automatic formatting.
4. In the Digits field, enter 6 and select Significant digits from the Precision Type pull-down menu.
5. Place a checkmark in the Hide trailing zeros checkbox.
6. Select Amplitude (Y-Axis) from the top pull-down menu and repeat steps 3–5 so the y-axis configuration matches the x-axis configuration.
8. Remove the checkmark from the Autoscale checkbox.
9. Enter -2.5 in the Minimum text box and 2.5 in the Maximum text box.
10. Click the OK button to save the configuration and close the Graph Properties dialog box.
11. Repeat steps 1–10 to configure the Filtered Signal graph indicator.

The x-axis and the y-axis on the Unfiltered Signal and Filtered Signal graph indicators change to reflect the new configuration.

### Analyzing the Amplitude of a Signal

You can use the Amplitude and Level Measurements Express VI to analyze the voltage characteristics of a signal.

Complete the following steps to reconfigure the Express VI to measure the peak-to-peak amplitude values of the signal.

1. On the block diagram, double-click the Amplitude and Level Measurements Express VI to display the Configure Amplitude and Level Measurements dialog box.
2. In the Amplitude Measurements section, remove the checkmark from the RMS checkbox.
3. Place a checkmark in the Peak to peak checkbox. Peak to peak appears in the Results section with the corresponding value of the measurement.
4. Click the **OK** button to save the current configuration and close the **Configure Amplitude and Level Measurements** dialog box. The **RMS** output of the Amplitude and Level Measurements Express VI changes to reflect the new **Peak to Peak** output, shown at left. You will use the **Peak to Peak** output in a later exercise.

**Controlling the Speed of Execution**

To plot the points on the waveform graphs more slowly, you can add a time delay to the block diagram.

Complete the following steps to **control the speed at which the VI runs**.

1. Search for the Time Delay Express VI.
2. Place the Time Delay Express VI in the lower left-hand corner of the While Loop. The **Configure Time Delay** dialog box appears.
3. Enter .1 in the **Time delay (seconds)** text box and click the **OK** button.
4. Run the VI.
   The loop iterates once every tenth of a second.

**Adding a Warning Light**

If you want a visual cue to indicate when a value exceeds a specified limit, you can use a warning light.

Complete the following steps to **add a warning light to the VI**.

1. On the front panel, display the **Controls** palette by right-clicking any blank space on the front panel.
2. On the **Express** palette, select the **LEDs** palette, shown in Figure 3-4.

![Figure 3-4. LEDs Palette](image-url)
3. Select the round LED indicator and place it on the front panel to the left of the waveform graphs.

4. Double-click the Boolean label above the LED and enter Warning to change the label of the LED.
   You will use this LED in a later exercise to indicate when a value has exceeded its limit.

5. Select File»Save As to display the Save As dialog box.

6. Read the various dialog box options. Select the Copy and Substitute copy for original radio buttons to create a copy of the original VI and immediately edit the copy.

7. Click the Continue button and save the VI as Warning Light.vi in an easily accessible location.

**Setting a Warning Level Limit**

To specify the value at which you want the LED to light, use the Comparison Express VI.

Complete the following steps to compare the peak-to-peak value to a limit you set.

8. Search for the Comparison Express VI and place it to the right of the Amplitude and Level Measurements Express VI. The Configure Comparison dialog box appears.

9. In the Compare Condition section, select the > Greater option.

10. In the Comparison Inputs section, select Value and enter 2 in the Value text box to assign a constant value at which you want the LED to light.

11. Click the OK button to save the current configuration and close the Configure Comparison dialog box.
   The name of the Comparison Express VI changes to reflect the operation of the Express VI, shown at left. Greater indicates that the Express VI does a greater than comparison.

12. Wire the Peak to Peak output of the Amplitude and Level Measurements Express VI to the Operand 1 input of the Greater Express VI.

13. Move the cursor over the wire that connects the Peak to Peak output to the Operand 1 input.

14. When the Positioning tool appears, right-click the wire that connects the Peak to Peak output to the Operand 1 input and select Create» Numeric Indicator from the shortcut menu.
A **Peak to Peak** terminal, shown at left, appears on the block diagram. If the **Peak to Peak** terminal appears to be on top of the wires between the Express VIs, move the Express VIs and **Peak to Peak** terminal around to create more space. For example, move the **Peak to Peak** terminal into blank space above the Express VIs.

**Warning the User**

After you specify the values at which you want the LED to light, you must wire the LED to the Greater Express VI.

Complete the following steps to provide a visual cue when the peak-to-peak value of the signal exceeds a specified limit.

1. On the block diagram, move the **Warning** terminal to the right of the Greater Express VI. Make sure the **Warning** terminal is inside the While Loop, as shown in Figure 3-5.

![Figure 3-5. Block Diagram of the Warning Light VI](image)

2. Wire the **Result** output of the Greater Express VI to the **Warning** terminal.
   The block diagram should appear similar to Figure 3-5.

3. Display the front panel.
   A numeric indicator labeled **Peak to Peak** appears on the front panel. This indicator displays the peak-to-peak value of the signal.

4. Run the VI.
When the peak-to-peak value exceeds 2.0, the Warning indicator lights.

5. Click the STOP button to stop the VI.
6. Save the VI.

**Configuring a VI to Save Data to a File**

To store information about the data a VI generates, use the Write To Measurement File Express VI.

Complete the following steps to build a VI that saves peak-to-peak values and other information to a LabVIEW data file.

1. Search for the Write To Measurement File Express VI and place it on the block diagram below and to the right of the Amplitude and Level Measurements Express VI.

   The Configure Write To Measurement File dialog box appears.

   The **File Name** text box displays the full path to the output file, `test.lvm`. A `.lvm` file is a tab-delimited text measurement file you can open with a spreadsheet application or a text-editing application. LabVIEW saves data with up to six digits of precision in a `.lvm` file. LabVIEW saves the `.lvm` file in the default LabVIEW Data directory. LabVIEW installs the LabVIEW Data directory in the default file directory of the operating system.

   When you want to view the data, use the file path displayed in the **File Name** text box to access the `test.lvm` file.

2. In the If a file already exists section of the Configure Write To Measurement File dialog box, select the **Append to file** option to write all the data to the `test.lvm` file without erasing any existing data in the file.

3. In the Segment Headers section, select the **One header only** option to create only one header in the file to which LabVIEW writes the data.

4. Enter the following text in the **File Description** text box: *Sample of peak to peak values*. LabVIEW appends the text you enter in this text box to the header of the file.

5. Click the **OK** button to save the current configuration and close the Configure Write To Measurement File dialog box.
Saving Data to a File

When you run the VI, LabVIEW saves the data to the test.lvm file.

Complete the following steps to generate the test.lvm file.

1. On the block diagram, wire the Peak to Peak output of the Amplitude and Level Measurements Express VI to the Signals input of the Write To Measurement File Express VI.
2. Select File>Save As and save the VI as Save Data.vi in an easily accessible location.
3. Display the front panel and run the VI.
4. Click the STOP button on the front panel.
5. To view the data you saved, open the test.lvm file in the LabVIEW Data directory with a spreadsheet or text-editing application.
   The file has a header which contains information about the Express VI.
6. Close the file after you finish looking at it and return to the Save Data VI.

Adding a Button That Stores Data When Clicked

If you want to store only certain data points, you can configure the Write To Measurement File Express VI to save peak-to-peak values only when a user clicks a button.

Complete the following steps to add a button to the VI and configure how the button responds when a user clicks it.

1. Search the Controls palette for the rocker button. Select one of the rocker buttons and place it to the right of the waveform graphs.
2. Right-click the rocker button and select Properties from the shortcut menu to display the Boolean Properties dialog box.
3. Change the label of the button to Write to File.
4. On the Operation page of the Boolean Properties dialog box, select Latch when pressed from the Button behavior list.
   Use the Operation page to specify how a button behaves when a user clicks it. To see how the button reacts to a click, click the button in the Preview Selected Behavior section.
5. Click the OK button to save the current configuration and close the Boolean Properties dialog box.
6. Save the VI.
Saving Data When Prompted by a User

Complete the following steps to build a VI that logs data to a file when the user clicks a button on the front panel.

1. On the block diagram, double-click the Write To Measurement File Express VI to display the Configure Write To Measurement File dialog box.
2. Change the filename `test.lvm` in the File Name text box to `Selected Samples.lvm` to save the data to a different file.
3. Click the OK button to save the current configuration and close the Configure Write To Measurement File dialog box.
4. Right-click the Signals input of the Write To Measurement File Express VI and select Insert Input/Output from the shortcut menu to insert the Comment input.
5. Right-click the Comment input of the Write To Measurement File Express VI and select Select Input/Output > Enable from the shortcut menu to replace the Comment input with the Enable input.
   The inputs and outputs of an Express VI appear in a predetermined order when you add new inputs and outputs. To select a specific input, you might need to add an input first, then change the input to the specific one you want to use by right-clicking the input and selecting Select Input/Output from the shortcut menu.
6. Move the Write to File terminal to the left of the Write To Measurement File Express VI.
7. Wire the Write to File terminal to the Enable input of the Write To Measurement File Express VI.
Chapter 3  Full and Professional: Analyzing and Saving a Signal

The block diagram should appear similar to Figure 3-6.

![Figure 3-6. Block Diagram of the Save Data VI](image)

**Viewing Saved Data**

Complete the following steps to view the data that you save to the `Selected Samples.lvm` file.

1. Display the front panel and run the VI. Click the **Write to File** button several times.
2. Click the **STOP** button on the front panel.
3. Open the `Selected Samples.lvm` file with a spreadsheet or text-editing application.
   
   The `Selected Samples.lvm` file differs from the `test.lvm` file. `test.lvm` recorded all the data generated by the Save Data VI, whereas `Selected Samples.lvm` recorded data only when you clicked the **Write to File** button.
4. Close the file after you finish looking at it.
5. Save and close the VI.
This chapter introduces you to the Express VIs you use to acquire data and communicate with instruments on Windows. These exercises require data acquisition hardware.

Refer to the Taking Measurements book on the Contents tab in the LabVIEW Help for information about acquiring data and communicating with instruments on all platforms.

**Acquiring a Signal**

In the following exercises, you will use the DAQ Assistant Express VI to create a task in NI-DAQmx. NI-DAQmx is a programming interface you can use to communicate with data acquisition devices. Refer to the Getting Started»Getting Started with DAQ»Taking an NI-DAQmx Measurement in LabVIEW book on the Contents tab in the LabVIEW Help for information about additional methods you can use to create NI-DAQmx tasks.

The following exercises require that you have NI-DAQmx and an NI-DAQmx-supported device. Refer to the NI-DAQ Readme for the list of NI-DAQmx-supported devices. If you have a device that is supported only with Traditional NI-DAQ, refer to the Taking Measurements book on the Contents tab in the LabVIEW Help for information about using Traditional NI-DAQ (Legacy) for data acquisition.

**Note** With NI-DAQmx 7.4 or later you can create NI-DAQmx simulated devices in MAX. An NI-DAQmx simulated device is a software replica of a DAQ device. Refer to the Measurement & Automation Explorer Help for NI-DAQmx for detailed instructions on creating an NI-DAQmx simulated device that you can use to complete the following exercises.
In the following exercises, you will create an NI-DAQmx task that continuously takes a voltage reading and plots the data on a waveform graph.

You can complete the exercises in this chapter in approximately 30 minutes.

Creating an NI-DAQmx Task

In NI-DAQmx, a task is a collection of one or more channels, timing, triggering, and other properties. Conceptually, a task represents a measurement or generation you want to perform. For example, you can create a task to measure temperature from one or more channels on a DAQ device.

Complete the following steps to create and configure a task that reads a voltage level from a DAQ device:

1. Open a new VI.
2. On the block diagram, display the Functions palette and select Express\>Input to display the Input palette.
3. Select the DAQ Assistant Express VI, shown at left, on the Input palette and place it on the block diagram. The DAQ Assistant launches and the Create New dialog box appears.
4. Click Analog Input to display the Analog Input options.
5. Select Voltage to create a new voltage analog input task.
   The dialog box displays a list of channels on each installed DAQ device. The number of channels listed depends on the number of channels you have on the DAQ device.
6. In the Supported Physical Channels list, select the physical channel to which the instrument connects the signal, such as ai0, and then click the Finish button. The DAQ Assistant opens a new dialog box, shown in Figure 4-1, which displays options for configuring the channel you selected to complete a task.
7. In the **Input Range** section of the **Settings** page, enter **10** for the **Max** value and enter **-10** for the **Min** value.

8. On the **Task Timing** page, select the **N Samples** option.

9. Enter a value of **1000** in the **Samples To Read** text box.
Testing the Task

You can test the task to verify that you correctly configured the channel. Complete the following steps to confirm that you are acquiring data.

1. Click the Test button, shown at left. The DAQ Assistant dialog box appears.
2. Click the Start button once or twice to confirm that you are acquiring data, and then click the Close button to return to the DAQ Assistant.
3. Click the OK button to save the current configuration and close the DAQ Assistant. LabVIEW builds the VI.
4. Save the VI as Read Voltage.vi in an easily accessible location.

Graphing Data from a DAQ Device

You can use the task you created in the previous exercise to graph the data acquired from a DAQ device.

Complete the following steps to plot the data from the channel on a waveform graph and change the name of the signal.

1. On the block diagram, right-click the data output and select Create» Graph Indicator from the shortcut menu.
2. Display the front panel and run the VI three or four times. Observe the waveform graph.
   Voltage appears in the plot legend at the top of the waveform graph.
3. On the block diagram, right-click the DAQ Assistant Express VI and select Properties from the shortcut menu to open the DAQ Assistant.
4. Right-click Voltage in the list of channels and select Rename from the shortcut menu to display the Rename a channel or channels dialog box.

   Tip  You also can select the name of the channel and press the <F2> key to display the Rename a channel or channels dialog box.

5. In the New Name text box, enter First Voltage Reading, and click the OK button.
6. In the DAQ Assistant dialog box, click the OK button to save the current configuration and close the DAQ Assistant.
7. Display the front panel and run the VI.
   First Voltage Reading appears in the waveform graph plot legend.
8. Save the VI.
Editing an NI-DAQmx Task

You can add a channel to the task so you can compare two separate voltage readings. You also can customize the task to acquire the voltage readings continuously.

Complete the following steps to add a new channel to the task and acquire data continuously.

1. On the block diagram, double-click the DAQ Assistant Express VI to open the DAQ Assistant.
2. Click the Add Channels button, shown at left, and select the Voltage channel from the Add Channel menu to display the Add Channels To Task dialog box.
3. Select any unused physical channel in the Supported Physical Channels list, and click the OK button to return to the DAQ Assistant.
4. Rename the channel Second Voltage Reading.
5. On the Task Timing page, select the Continuous option. When you set timing and triggering options in the DAQ Assistant, these options apply to all the channels in the list of channels.
6. Click the OK button to save the current configuration and close the DAQ Assistant. The Confirm Auto Loop Creation dialog box appears.
7. Click the Yes button. LabVIEW places a While Loop around the DAQ Assistant Express VI and the graph indicator. A stop button appears on the block diagram wired to the stop input of the DAQ Assistant Express VI. The stopped output of the Express VI is wired to the conditional terminal of the While Loop. The block diagram should appear similar to Figure 4-2.

Figure 4-2. Block Diagram of the Read Voltage VI

If an error occurs or you click the stop button while the VI is running, the DAQ Assistant Express VI stops reading data and the stopped output returns a TRUE value and stops the While Loop.
Visually Comparing Two Voltage Readings

Because you have two voltage readings displayed on a graph, you can customize the plots to distinguish between the two.

Complete the following steps to customize the plot color on the waveform graph.

1. On the front panel, expand the plot legend to display two plots.
2. Run the VI.
   Two plots appear on the graph, and the plot legend displays both plot names.
3. Right-click First Voltage Reading in the plot legend and select Color from the shortcut menu. Using the color picker, select a color such as yellow so the plot is easy to read. Change the plot color of Second Voltage Reading.
4. Save the VI.

Communicating with an Instrument

Instrument drivers simplify instrument control and reduce test program development time by eliminating the need to learn the programming protocol for each instrument. An instrument driver is a set of software routines that control a programmable instrument. Each routine corresponds to a programmatic operation such as configuring, reading from, writing to, and triggering the instrument. Use an instrument driver for instrument control when possible. National Instruments provides thousands of instrument drivers for a wide variety of instruments.

In the following exercises, you will communicate with an instrument.

Finding and Installing Instrument Drivers (Windows and Linux)

Use the NI Instrument Driver Finder to search for and install LabVIEW Plug and Play instrument drivers without leaving the LabVIEW development environment.

Note The Instrument Driver Finder is available only on Windows and Linux. You must have Internet access to use the Instrument Driver Finder.

You also can visit the NI Instrument Driver Network at ni.com/idnet to find a driver for an instrument.